Tidy up Makefiles
[openwrt-10.03/.git] / rules.mk
index b63fcf31c8f5f7a6934473e64992f4188263599c..4bc7dfab48e538aaf511e6051f85b567212fb71d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -83,12 +83,14 @@ TARGET_CONFIGURE_OPTS:= \
   CXX=$(TARGET_CROSS)g++ \
   RANLIB=$(TARGET_CROSS)ranlib \
   STRIP=$(TARGET_CROSS)strip \
-  OBJCOPY=$(TARGET_CROSS)objcopy
+  OBJCOPY=$(TARGET_CROSS)objcopy \
+       OBJDUMP=$(TARGET_CROSS)objdump
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages
@@ -129,6 +131,18 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
+# Default targets for subdirectory calls
+# Parameters:
+#      1: dependencies for the prepare step
+define default_subtargets
+  %-download %-prepare %-compile %-install %-clean: FORCE
+       $$(MAKE) -C $$* $$(patsubst $$*-%,%,$$@)
+
+  %-compile: %-prepare 
+  %-install: %-compile
+  .SILENT: %-clean
+endef
+
 
 all:
 FORCE: ;