[package] globally define IPv6 support or not in OpenWrt, just like for largefiles...
[openwrt-10.03/.git] / rules.mk
index 05609b9ac03afaec2df13fae2d1d214ec9f89ee1..3f39eefd7b6320c21495bc05560e7d40875009fb 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -153,13 +153,21 @@ else
 endif
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
-  DISABLE_NLS:=
+  DISABLE_NLS:=--enable-nls
 else
   DISABLE_NLS:=--disable-nls
 endif
 
-ifneq ($(CONFIG_LARGEFILE),y)
-  DISABLE_LARGEFILE= --disable-largefile
+ifeq ($(CONFIG_IPV6),y)
+  DISABLE_IPV6:=--enable-ipv6
+else
+  DISABLE_IPV6:=--disable-ipv6
+endif
+
+ifeq ($(CONFIG_LARGEFILE),y)
+  DISABLE_LARGEFILE:=
+else
+  DISABLE_LARGEFILE:=--disable-largefile
 endif
 
 ifeq ($(CONFIG_TAR_VERBOSITY),y)