clean up recursive dependency handling, use timestamp.pl again, because it saves...
[openwrt-10.03/.git] / rules.mk
index e76c75d04b7dc3677f20172a7af931dd7ca8b355..3885a86953ff56dbb302a47327ee2a8ca6931254 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -8,6 +8,7 @@
 ifeq ($(DUMP),)
   -include $(TOPDIR)/.config
 endif
+include $(TOPDIR)/include/debug.mk
 include $(TOPDIR)/include/verbose.mk
 
 TMP_DIR:=$(TOPDIR)/tmp
@@ -25,6 +26,7 @@ ARCH:=$(call qstrip,$(CONFIG_ARCH))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
 BUILD_SUFFIX:=$(call qstrip,$(CONFIG_BUILD_SUFFIX))
 GCCV:=$(call qstrip,$(CONFIG_GCC_VERSION))
+SUBDIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
 
 OPTIMIZE_FOR_CPU:=$(ARCH)