minor makefile tweaks
[openwrt-10.03/.git] / rules.mk
index d762ae79ed4c68aff37b09fc65a1a2d69dfc6860..206e57dd03e1f6cd2a461ccf1194307166328481 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -1,4 +1,12 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 -include $(TOPDIR)/.config
+include $(TOPDIR)/include/verbose.mk
 
 export SHELL=/bin/bash
 
@@ -20,6 +28,7 @@ BIN_DIR:=$(TOPDIR)/bin
 PACKAGE_DIR:=$(BIN_DIR)/packages
 IPKG_TARGET_DIR:=$(PACKAGE_DIR)
 BUILD_DIR:=$(TOPDIR)/build_$(ARCH)
+TMP_DIR:=$(BUILD_DIR)/tmp
 STAMP_DIR:=$(BUILD_DIR)/stamp
 TARGET_DIR:=$(BUILD_DIR)/root
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/ipkg
@@ -108,3 +117,4 @@ endif
 all:
 FORCE: ;
 .PHONY: FORCE
+%: ;