move ccache dir to staging_dir_arch (removing the staging dir will make the ccache...
[openwrt-10.03/.git] / rules.mk
index f0d21a279759e12840cb85ab5089080bd90baa87..0ec5daf086e354ba60fc884dabbf7a0c2da2fcc7 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -60,7 +60,7 @@ CP:=cp -fpR
 
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(TOPDIR)/ccache_$(ARCH)
+  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
@@ -106,7 +106,7 @@ IPKG:= \
 
 # invoke ipkg-build with some default options
 IPKG_BUILD:= \
-  ipkg-build -c -o root -g root
+  ipkg-build -c -o 0 -g 0
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
   DISABLE_NLS:=