mac80211: fix duplicate probe request reception (triggering unnecessary probe respons...
[openwrt-10.03/.git] / rules.mk
index 86c8f8cf6d7ae8d235f6ec3d949cc88059335823..0068350ed2ed22624996117e2ae5d6527e7fca11 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -27,6 +27,10 @@ merge=$(subst $(space),,$(1))
 confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
 strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 
+define sep
+
+endef
+
 _SINGLE=export MAKEFLAGS=$(space);
 CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
@@ -170,8 +174,6 @@ INSTALL_DATA:=install -m0644
 INSTALL_CONF:=install -m0600
 
 ifneq ($(CONFIG_CCACHE),)
-  # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
 endif