add a config item to specify arguments to strip
[openwrt-10.03/.git] / rules.mk
index 31c8854e9d222fcb0975cdd07b0e7fd7af3842ae..3473b212de4b6b4c1e054e435517c50b88117694 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -174,7 +174,7 @@ ifneq ($(CONFIG_NO_STRIP),)
   STRIP:=:
 else
   ifneq ($(CONFIG_USE_STRIP),)
-    STRIP:=$(TARGET_CROSS)strip
+    STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS))
   else
     ifneq ($(CONFIG_USE_SSTRIP),)
       STRIP:=$(STAGING_DIR_HOST)/bin/sstrip