major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / package / yamonenv / Makefile
index dfb0c82f965bbc4e19bcb94f0c6e17f6306b8d11..9a323c28d8d3dcfec34101c814e6233e415f5512 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4091 2006-06-27 00:35:46Z mbm $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -12,34 +12,27 @@ PKG_NAME:=yamonenv
 PKG_VERSION:=20051022
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_SOURCE:=$(PKG_NAME)_gruen.4g__$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://meshcube.org/nylon/stable/sources/
 PKG_MD5SUM:=a3e4f24155aa3ba5aa502bc63fdaa6ad
-PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/yamonenv
-SECTION:=sys
-CATEGORY:=Base system
-DEPENDS:=@LINUX_2_6_AU1000@
-TITLE:=YAMON configuration utility
-DESCRIPTION:=YAMON bootloader configuration utility
-URL:=http://meshcube.org/nylon/stable/sources/
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@TARGET_au1000
+  TITLE:=YAMON configuration utility
+  URL:=http://meshcube.org/nylon/stable/sources/
 endef
 
 define Build/Configure
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default,all)
-endef
-
 define Package/yamonenv/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
 endef