wprobe: use libnl-tiny instead of libnl
[openwrt-10.03/.git] / package / wprobe / Makefile
index 89f0450f02ad26d0c9e859c23f662a315d37f219..7b49b6598fceed10c6cd8da17c0d43ba04157dd0 100644 (file)
@@ -10,7 +10,11 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=wprobe
 PKG_VERSION:=1
 
-PKG_BUILD_DEPENDS:=libnl libipfix
+PKG_BUILD_DEPENDS:=PACKAGE_wprobe-export:libipfix
+
+PKG_CONFIG_DEPENDS = \
+       CONFIG_PACKAGE_kmod-wprobe \
+       CONFIG_PACKAGE_wprobe-export \
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,7 +33,7 @@ endef
 define Package/wprobe-info
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-wprobe
+  DEPENDS:=+kmod-wprobe +libnl-tiny
   TITLE:=Wireless measurement utility
 endef
 
@@ -41,7 +45,7 @@ endef
 define Package/wprobe-export
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-wprobe
+  DEPENDS:=+kmod-wprobe +libnl-tiny
   TITLE:=Wireless measurement data exporter
 endef
 
@@ -55,9 +59,12 @@ define Build/Prepare
        $(CP) src/* $(PKG_BUILD_DIR)/
 endef
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += \
+       -I$(STAGING_DIR)/usr/include/libnl-tiny \
+       -I$(STAGING_DIR)/usr/include
 
-define Build/Compile/kmod
+ifdef CONFIG_PACKAGE_kmod-wprobe
+  define Build/Compile/kmod
        $(MAKE) -C $(LINUX_DIR) \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                ARCH="$(LINUX_KARCH)" \
@@ -66,7 +73,8 @@ define Build/Compile/kmod
                CC="$(TARGET_CC)" \
                EXTRA_CFLAGS="-I$(PKG_BUILD_DIR)/kernel" \
                modules
-endef
+  endef
+endif
 
 define Build/Compile/lib
        $(MAKE) -C $(PKG_BUILD_DIR)/user \
@@ -74,17 +82,19 @@ define Build/Compile/lib
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="$(TARGET_CPPFLAGS) -I$(PKG_BUILD_DIR)/kernel" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBNL="$(STAGING_DIR)/usr/lib/libnl.a"
+               LIBNL="-lnl-tiny"
 endef
 
-define Build/Compile/exporter
+ifdef CONFIG_PACKAGE_wprobe-export
+  define Build/Compile/exporter
        $(MAKE) -C $(PKG_BUILD_DIR)/exporter \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="$(TARGET_CPPFLAGS) -I$(PKG_BUILD_DIR)/kernel -I$(PKG_BUILD_DIR)/user" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBS="$(PKG_BUILD_DIR)/user/libwprobe.a $(STAGING_DIR)/usr/lib/libipfix.a $(STAGING_DIR)/usr/lib/libmisc.a $(STAGING_DIR)/usr/lib/libnl.a -lm"
-endef
+               LIBS="$(PKG_BUILD_DIR)/user/libwprobe.a $(STAGING_DIR)/usr/lib/libipfix.a $(STAGING_DIR)/usr/lib/libmisc.a -lnl-tiny -lm"
+  endef
+endif
 
 define Build/Compile
        $(Build/Compile/kmod)
@@ -93,8 +103,8 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/kernel/linux $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include/wprobe
+       $(CP) $(PKG_BUILD_DIR)/kernel/linux $(1)/usr/include/wprobe
 endef
 
 define Package/wprobe-info/install
@@ -103,7 +113,8 @@ define Package/wprobe-info/install
 endef
 
 define Package/wprobe-export/install
-       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/wprobe.init $(1)/etc/init.d/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/exporter/wprobe-export $(1)/sbin/
 endef