add _GNU_SOURCE to CPPFLAGS required to include <bits/socket.h> on recent eglibc...
[openwrt-10.03/.git] / package / wprobe / Makefile
index 379aa37c2aca33a67e1ab3928cd68e692f7762b6..536a85eb2a7294424a901e4d6dd927cb295b7813 100644 (file)
@@ -61,13 +61,14 @@ define Build/Prepare
 endef
 
 TARGET_CPPFLAGS := \
+       -D_GNU_SOURCE \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        $(TARGET_CPPFLAGS)
 
 ifdef CONFIG_PACKAGE_kmod-wprobe
   define Build/Compile/kmod
        $(MAKE) -C $(LINUX_DIR) \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
+               CROSS_COMPILE="$(KERNEL_CROSS)" \
                ARCH="$(LINUX_KARCH)" \
                SUBDIRS="$(PKG_BUILD_DIR)/kernel" \
                KERNELDIR=$(LINUX_DIR) \