implement target profiles in menuconfig
[openwrt-10.03/.git] / package / wlcompat / Makefile
index d5feede6c952964e0f333c2030a36792676613f3..4a372946581cd7241f4874ef839cc3bbfae89ed1 100644 (file)
@@ -1,34 +1,43 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kmod-wlcompat
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kmod-wlcompat/Default
+  SECTION:=kernel
+  CATEGORY:=Kernel drivers
+  DEPENDS:=@PACKAGE_kmod-brcm-wl||PACKAGE_kmod-brcm-wl-mimo +wireless-tools
+  DEFAULT:=y
+  TITLE:=Broadcom wl wrapper module
+  DESCRIPTION:=\
+       This package contains a wrapper module, that provides Wireless Extension \\\
+       support for the proprietary Broadcom wl module.
+  VERSION:=$(LINUX_VERSION)+$(BOARD)-$(PKG_RELEASE)
+endef
 
 define Package/kmod-wlcompat
-SECTION:=drivers
-CATEGORY:=Drivers
-DEPENDS:=kmod-brcm-wl
-DEFAULT:=y
-TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module
-DESCRIPTION:= \\\
-A wrapper module, that provides Wireless Extension support for the \\\
-proprietary Broadcom wl module.
-VERSION:=$(LINUX_VERSION)+$(BOARD)-$(PKG_RELEASE)
+  $(call Package/kmod-wlcompat/Default)
 endef
 
 define Package/kmod-wlcompat-debug
-$(call Package/kmod-wlcompat)
-DEFAULT:=m
-TITLE:=Wrapper providing Wireless Extensions for Broadcom wl module (debug)
-DESCRIPTION:= \\\
-A wrapper module, that provides Wireless Extension support for the \\\
-proprietary Broadcom wl module.
+  $(call Package/kmod-wlcompat/Default)
+  TITLE+= (debug)
+  DESCRIPTION+=\\\
+       \\\
+       This is a debugging version.
 endef
 
 define Build/Prepare
@@ -40,7 +49,6 @@ define Build/Compile
        $(MAKE) -C "$(LINUX_DIR)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                ARCH="$(LINUX_KARCH)" \
-               PATH="$(TARGET_PATH)" \
                SUBDIRS="$(PKG_BUILD_DIR)" \
                EXTRA_CFLAGS="-DDEBUG -I$(LINUX_DIR)/arch/mips/bcm947xx/include -I$(PKG_BUILD_DIR)/include" \
                modules
@@ -48,17 +56,16 @@ define Build/Compile
        $(MAKE) -C "$(LINUX_DIR)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                ARCH="$(LINUX_KARCH)" \
-               PATH="$(TARGET_PATH)" \
                SUBDIRS="$(PKG_BUILD_DIR)" \
                EXTRA_CFLAGS="-I$(LINUX_DIR)/arch/mips/bcm947xx/include -I$(PKG_BUILD_DIR)/include" \
                modules
 endef
 
 define Package/kmod-wlcompat/install
-       install -d -m0755 $(1)/etc/modules.d
-       echo "wlcompat" > $(1)/etc/modules.d/30-wlcompat
        install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_BUILD_DIR)/wlcompat.o $(1)/lib/modules/$(LINUX_VERSION)/
+       install -d -m0755 $(1)/etc/modules.d
+       echo "wlcompat" > $(1)/etc/modules.d/30-wlcompat
 endef
 
 define Package/kmod-wlcompat-debug/install