same propset here as changeset:6500
[openwrt-10.03/.git] / package / util-linux / Makefile
index 8ca8052ea12844506582d0baafc511c3666fa070..5fc819bcfffb8d12b6684e5f5662b2c4d1513f9e 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 3822 2006-05-24 07:01:52Z nico $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -56,6 +56,7 @@ define Package/swap-utils
        - swapoff
 endef
 
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
 define Build/Compile
        $(call Build/Compile/Default, \
                OPT="$(TARGET_CFLAGS)" \
@@ -70,7 +71,7 @@ define Package/Template
                rm -f $(PKG_BUILD_DIR)/.built; \
                $(MAKE) $(PKG_BUILD_DIR)/.built; \
        fi
-       install -d -m0755 $(2)
+       $(INSTALL_DIR) $(2)
        $(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
 endef