[backfire] merge r28254
[openwrt-10.03/.git] / package / uhttpd / Makefile
index 3e7344911b5dc1bd957c7dccc547620439ca1090..a43b1014f8c9d10cbc6e4d0a3a8b346073857c54 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2011 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,10 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=2
+PKG_RELEASE:=23.3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DEPENDS := libcyassl liblua
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -56,6 +57,7 @@ endef
 
 # hack to use CyASSL headers
 TARGET_CFLAGS += -I$(firstword $(wildcard $(BUILD_DIR)/cyassl-*/include))
+TARGET_LDFLAGS += -lm
 MAKE_VARS += FPIC="$(FPIC)"
 
 define Build/Prepare
@@ -65,6 +67,8 @@ endef
 
 define Package/uhttpd/conffiles
 /etc/config/uhttpd
+/etc/uhttpd.crt
+/etc/uhttpd.key
 endef
 
 define Package/uhttpd/install