ath9k: due to popular request, allow ad-hoc+ap again, now that the beacon code can...
[openwrt-10.03/.git] / package / udevtrigger / Makefile
index 435ad8fd6b08acb1253b23a7e67709112b4d37a8..d229c13032a1c98955d9944578b01162b27119f6 100644 (file)
@@ -20,11 +20,12 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/udev-$(PKG_VERSION)
 include $(INCLUDE_DIR)/package.mk
 
 define Package/udevtrigger
-       SECTION:=base
-       CATEGORY:=Base system
-       TITLE:=Small utility to request kernel devices events for coldplug
-       URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
-       MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+  SECTION:=base
+  CATEGORY:=Base system
+  DEPENDS:=@LINUX_2_6
+  TITLE:=Small utility to request kernel devices events for coldplug
+  URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
+  MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 endef
 
 define Build/Compile
@@ -32,6 +33,7 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                STRIP="/bin/true" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               OPTFLAGS="$(TARGET_CFLAGS)" \
                udevtrigger
 endef