clean up the directory layout of the uci shell api
[openwrt-10.03/.git] / package / uci / Makefile
index ecc53b0890b89d5a1e84192e25044431d23a8479..3214c20bc5733e6a7869512bad8c9aaa98f0ddfc 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 UCI_VERSION=0.4
-UCI_RELEASE=2
+UCI_RELEASE=4
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
@@ -17,7 +17,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=503b3faa92bb9f5d780ca96efb7dfd75
+PKG_MD5SUM:=1ce8e92e3aa023763e8f4da91a70563d
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,13 +37,6 @@ define Package/uci
   TITLE:=Utility for the Unified Configuration Interface (UCI)
 endef
 
-define Package/uci-sh
-  SECTION:=base
-  CATEGORY:=Base system
-  DEPENDS:=@!PACKAGE_uci
-  TITLE:=Old shell/awk implementation of UCI
-endef
-
 define Package/libuci-lua
   SECTION=libs
   CATEGORY=Libraries
@@ -78,14 +71,10 @@ define Package/libuci-lua/install
 endef
 
 define Package/uci/install
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uci $(1)/sbin/
-       $(CP) ./files/uci/* $(1)/
-endef
-
-define Package/uci-sh/install
-       $(INSTALL_DIR) $(1)
-       $(CP) ./files/uci-sh/* $(1)/
+       $(CP) ./files/* $(1)/
 endef
 
 define Build/InstallDev
@@ -98,4 +87,3 @@ endef
 $(eval $(call BuildPackage,uci))
 $(eval $(call BuildPackage,libuci))
 $(eval $(call BuildPackage,libuci-lua))
-$(eval $(call BuildPackage,uci-sh))