drop ifxmips
[openwrt-10.03/.git] / package / uboot-ifxmips / patches / 110-compile_fix.patch
diff --git a/package/uboot-ifxmips/patches/110-compile_fix.patch b/package/uboot-ifxmips/patches/110-compile_fix.patch
deleted file mode 100644 (file)
index 34d0ac6..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/cpu/mips/Makefile
-+++ b/cpu/mips/Makefile
-@@ -36,6 +36,9 @@ START        := $(addprefix $(obj),$(START))
- all:  $(obj).depend $(START) $(LIB)
-+start.o: start.S
-+      $(CC) $(AFLAGS) -fPIC -c -o $@ $<
-+
- $(LIB):       $(OBJS)
-       $(AR) $(ARFLAGS) $@ $(OBJS)
---- a/Makefile
-+++ b/Makefile
-@@ -185,8 +185,8 @@ include $(TOPDIR)/config.mk
- OBJS  = cpu/$(CPU)/start.o
- OBJS_BOOTSTRAP  = cpu/$(CPU)/start_bootstrap.o
--cpu/$(CPU)/start_bootstrap.S: cpu/$(CPU)/start.S
--      ln -s start.S cpu/$(CPU)/start_bootstrap.S
-+cpu/$(CPU)/start_bootstrap.o: cpu/$(CPU)/start.S
-+      $(CC) $(AFLAGS) -fPIC -DCFG_BOOTSTRAP_CODE -c -o $@ $<
- ifeq ($(CPU),i386)
- OBJS += cpu/$(CPU)/start16.o