[package] add uboot-envtools
[openwrt-10.03/.git] / package / uboot-envtools / Makefile
diff --git a/package/uboot-envtools/Makefile b/package/uboot-envtools/Makefile
new file mode 100644 (file)
index 0000000..8a3600a
--- /dev/null
@@ -0,0 +1,34 @@
+# 
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=uboot-envtools
+PKG_VERSION:=20081215
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/u/uboot-envtools/
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/uboot-envtools
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=read/modify the environment for the bootloader U-Boot
+endef
+
+define Package/uboot-envtools/description
+endef
+
+define Package/uboot-envtools/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
+       ln -s fw_printenv $(1)/usr/sbin/fw_setenv
+endef
+
+$(eval $(call BuildPackage,uboot-envtools))