demistifying make *clean targets, fix some clean targets issues
[openwrt-10.03/.git] / package / sed / sed.mk
index 5154c1f795d5f2429d4da1cb7418183e65cf7e4b..8de0ea64cd1d6406244961a6475aed89aacba479 100644 (file)
@@ -69,7 +69,6 @@ use-sed-host-binary:
 host-sed: $(HOST_SED_TARGET)
 
 host-sed-clean:
-       $(MAKE) DESTDIR=$(STAGING_DIR) -C $(SED_DIR1) uninstall
        -$(MAKE) -C $(SED_DIR1) clean
 
 host-sed-dirclean:
@@ -127,10 +126,11 @@ sed-target_binary: $(SED_DIR2)/$(SED_BINARY)
 sed: uclibc sed-target_binary
 
 sed-clean:
-       $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(SED_DIR2) uninstall
        -$(MAKE) -C $(SED_DIR2) clean
 
 sed-dirclean:
        rm -rf $(SED_DIR2)
 
-
+ifeq ($(strip $(BR2_PACKAGE_SED)),y)
+TARGETS+=sed
+endif