change section from base to utils
[openwrt-10.03/.git] / package / robocfg / Makefile
index 81cf99ac237c32b49fdca9d51989914d78a58389..c0e7e2c21effd681a0faec513934676179292a94 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -8,23 +14,25 @@ PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/robocfg
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/robocfg
-SECTION:=base
-TITLE:=BCM5325E/536x switch configuration utility
-DESCRIPTION:=Broadcom BCM5325E/536x switch configuration utility
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=BCM5325E/536x switch configuration utility
+  DESCRIPTION:=\
+       This package contains an utility for configuring the Broadcom BCM5325E/536x \\\
+       based switches.
 endef
 
-define Build/Compile
-       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/robocfg robocfg.c
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
 define Package/robocfg/install
        install -d -m0755 $(1)/sbin
        install -m0755 $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
-       $(RSTRIP) $(1)
-       $(IPKG_BUILD) $(1) $(PACKAGE_DIR)
 endef
 
 $(eval $(call BuildPackage,robocfg))