[backfire] merge r27449
[openwrt-10.03/.git] / package / qos-scripts / Makefile
index d433172a7fd9c1ecc3d64b4d719555fda8eaa2f7..7a374697e5c5c31e467dcfd5fe5fac72e89ecef1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qos-scripts
 PKG_VERSION:=1.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -18,8 +18,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/qos-scripts
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+tc +kmod-sched +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-conntrack-extra +iptables-mod-imq
+  DEPENDS:=+tc +kmod-sched +iptables +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-conntrack-extra +iptables-mod-imq
   TITLE:=QoS scripts
+  PKGARCH:=all
 endef
 
 define Package/qos-scripts/description
@@ -28,6 +29,10 @@ define Package/qos-scripts/description
  entries.
 endef
 
+define Package/qos-scripts/conffiles
+/etc/config/qos
+endef
+
 define Build/Prepare
 endef