[backfire] qos-scripts: merge r28622 and r28623
[openwrt-10.03/.git] / package / qos-scripts / Makefile
index ae64d97e656387150e31c30ae6363d5cccda2791..4fe1fbff07cfe206fff038ebb46d46ef40f39d43 100644 (file)
@@ -1,16 +1,15 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qos-scripts
-PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
+PKG_VERSION:=1.2.1
+PKG_RELEASE:=3.1
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -19,8 +18,9 @@ include $(INCLUDE_DIR)/package.mk
 define Package/qos-scripts
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+tc +kmod-sched +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-conntrack +iptables-mod-imq
+  DEPENDS:=+tc +kmod-sched +iptables +iptables-mod-filter +iptables-mod-ipopt +iptables-mod-conntrack-extra +iptables-mod-imq
   TITLE:=QoS scripts
+  PKGARCH:=all
 endef
 
 define Package/qos-scripts/description
@@ -29,6 +29,10 @@ define Package/qos-scripts/description
  entries.
 endef
 
+define Package/qos-scripts/conffiles
+/etc/config/qos
+endef
+
 define Build/Prepare
 endef