rewrite of the network scripts and configuration
[openwrt-10.03/.git] / package / pptp / Makefile
index de7c50c2d44ffdc3b1442bb7efa7047d1f0b1062..b060c12a793b90ef46cf4b9c84f61cdb2928d4bb 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -12,7 +18,7 @@ PKG_SOURCE_URL:=@SF/pptpclient
 PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
 PKG_CAT:=zcat
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/pptp
 SECTION:=base
@@ -23,12 +29,12 @@ URL:=http://pptpclient.sourceforge.net/
 endef
 
 define Package/pptp/install
-       install -d -m0755 $(IDIR_PPTP)/sbin
-       install -d -m0755 $(IDIR_PPTP)/etc/ppp
-       install -d -m0755 $(IDIR_PPTP)/usr/sbin
-       install -m0755 ./files/ifup.pptp $(IDIR_PPTP)/sbin/ifup.pptp
-       install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
-       install -m0755 $(PKG_BUILD_DIR)/pptp $(IDIR_PPTP)/usr/sbin/
+       install -d -m0755 $(1)/etc/ppp
+       install -m0644 ./files/options.pptp $(1)/etc/ppp/
+       install -d -m0755 $(1)/lib/network
+       install -m0755 ./files/pptp.sh $(1)/lib/network/
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,pptp))