improve dependency handling, fix some package makefile bugs
[openwrt-10.03/.git] / package / ppp / Makefile
index 0139eb051f73a0f7b872756f35900a1742507b87..2f0140030895da84dcd5aa3385f79a64599a97d4 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.3
 PKG_RELEASE:=7
-PKG_BUILDDEP:=libpcap
+PKG_BUILDDEP:=libpcap linux-atm
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -30,7 +30,7 @@ endef
 define Package/ppp-mod-pppoa
  SECTION:=net
  CATEGORY:=Network
- DEPENDS:=ppp
+ DEPENDS:=ppp +linux-atm
  TITLE:=PPPoA plugin
  DESCRIPTION:=PPPoA (PPP over ATM) plugin for ppp
 endef