ar71xx: enable the ip17xx PHY driver (fixes #5193, #8027), backport of r26670
[openwrt-10.03/.git] / package / pcmcia-cs / Makefile
index e0474c48d0c3996ff64eda4506634395cdc5d107..384394b612c2e96e595e1c4daf90e5999f351980 100644 (file)
@@ -4,9 +4,9 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=pcmcia-cs
 PKG_VERSION:=3.2.8
@@ -15,19 +15,18 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_MD5SUM:=0d6d65be8896eff081aee996049afaa5
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pcmcia-cs
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@PCMCIA_SUPPORT
+  DEPENDS:=@LINUX_2_4 @PCMCIA_SUPPORT
   TITLE:=PCMCIA/Cardbus management utilities
   URL:=http://pcmcia-cs.sourceforge.net/
 endef
 
-$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
+$(STAMP_CONFIGURED): $(LINUX_DIR)/.config
 
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); \
@@ -62,8 +61,8 @@ define Package/pcmcia-cs/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/pcmcia $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,pcmcia-cs))