sync pcmcia-cs in trunk with whiterussian, add fix for memory ranges
[openwrt-10.03/.git] / package / pcmcia-cs / Makefile
index 2241c6f53b0fcc7e221976c2874c5d16e045e924..2e312fbf12ac1426efe72369b95a87a710b97a8d 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/pcmcia-cs
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_4&&PCMCIA_SUPPORT
+  DEPENDS:=@PCMCIA_SUPPORT
   TITLE:=PCMCIA/Cardbus management utilities
   URL:=http://pcmcia-cs.sourceforge.net/
 endef
@@ -58,9 +58,9 @@ define Build/Compile
 endef
 
 define Package/pcmcia-cs/install
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/pcmcia $(1)/etc/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardctl $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/cardmgr $(1)/usr/sbin/
 endef