replace lots of manual install commands with INSTALL_* variables
[openwrt-10.03/.git] / package / openswan / Makefile
index b5adc542576f72c0bf3cfc30ad1c149409a405d2..a644b20db0f38d56db305327aa21eb52928f3a9e 100644 (file)
@@ -73,7 +73,7 @@ endef
 
 define Package/openswan/install
        $(CP) $(PKG_INSTALL_DIR)/* $(1)
-       install -d -m0755 $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) ./files/ipsec.init $(1)/etc/init.d/ipsec
        rm -rf $(1)/usr/share
        rm -rf $(1)/usr/man