[backfire] openssl: bump to v0.9.8s (CVE-2011-4108, CVE-2011-4109, CVE-2011-4576...
[openwrt-10.03/.git] / package / openssl / Makefile
index 36b5b24e2757021f94bdca375ea384cf6ddbe22c..b3b18a5f0bf0455b3414168b912bf10aaa747b08 100644 (file)
@@ -1,23 +1,25 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8e
-PKG_RELEASE:=3
+PKG_VERSION:=0.9.8s
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=3a7ff24f6ea5cd711984722ad654b927
+PKG_MD5SUM:=fbf71e8e050bc1ec290b7468bab1a76e
+
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
+PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,25 +28,30 @@ define Package/openssl/Default
   URL:=http://www.openssl.org/
 endef
 
+define Package/libopenssl/config
+source "$(SOURCE)/Config.in"
+endef
+
 define Package/openssl/Default/description
- The OpenSSL Project is a collaborative effort to develop a robust, 
- commercial-grade, full-featured, and Open Source toolkit implementing the 
- Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) 
- protocols as well as a full-strength general purpose cryptography library.
+The OpenSSL Project is a collaborative effort to develop a robust,
+commercial-grade, full-featured, and Open Source toolkit implementing the Secure
+Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) protocols as well
+as a full-strength general purpose cryptography library.
 endef
 
 define Package/libopenssl
 $(call Package/openssl/Default)
   SECTION:=libs
+  SUBMENU:=SSL
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
+  MENU:=1
 endef
 
 define Package/libopenssl/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL shared libraries, needed by other 
- programs.
+This package contains the OpenSSL shared libraries, needed by other programs.
 endef
 
 define Package/openssl-util
@@ -61,15 +68,21 @@ endef
 
 define Package/openssl-util/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL command-line utility.
+This package contains the OpenSSL command-line utility.
 endef
 
 
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
-                                       no-engines no-sse2 no-perlasm
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic no-sse2
+
+ifdef CONFIG_OPENSSL_ENGINE
+  OPENSSL_OPTIONS += --with-cryptodev
+else
+  OPENSSL_OPTIONS += no-engines
+endif
 
+OPENSSL_OPTIONS += no-perlasm
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
@@ -84,52 +97,58 @@ define Build/Configure
        )
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
+       # XXX: OpenSSL "make depend" will look for installed headers before its own,
+       # so remove installed stuff first
+       -$(SUBMAKE) -j1 clean-staging
        $(MAKE) -C $(PKG_BUILD_DIR) \
                MAKEDEPPROG="$(TARGET_CROSS)gcc" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
                depend
+       $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               AR="$(TARGET_CROSS)ar r" \
+               RANLIB="$(TARGET_CROSS)ranlib" \
+               OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
+               all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
-               all build-shared
+               $(OPENSSL_MAKEFLAGS) \
+               build-shared
        # Work around openssl build bug to link libssl.so with libcrypto.so.
        -rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
                do_linux-shared
        $(MAKE) -C $(PKG_BUILD_DIR) \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               $(OPENSSL_MAKEFLAGS) \
                install
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,^includedir=.*,includedir=$(STAGING_DIR)/usr/include,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
-       $(SED) 's,^libdir=.*,libdir=$(STAGING_DIR)/usr/lib,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
-       $(SED) 's,$(TARGET_LDFLAGS),,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/openssl \
-               $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
+       $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
 
 define Package/libopenssl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
-       chmod 0644 $(1)/usr/lib/*
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libcrypto.so.* $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libssl.so.* $(1)/usr/lib/
 endef
 
 define Package/openssl-util/install
@@ -139,7 +158,7 @@ define Package/openssl-util/install
        $(INSTALL_DIR) $(1)/etc/ssl/private
        chmod 0700 $(1)/etc/ssl/private
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,libopenssl))