[package] openssl: update ocf to 20080917
[openwrt-10.03/.git] / package / openssl / Makefile
index 78844d28eceffae5433ed15ed593cf0a125d56bf..43ca3bed75f19e657f5827345900df31e1cc3bf5 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_VERSION:=0.9.8i
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -19,6 +19,8 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
 PKG_MD5SUM:=561e00f18821c74b2b86c8c7786f9d8b
 
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/openssl/Default
@@ -27,9 +29,9 @@ define Package/openssl/Default
 endef
 
 define Package/openssl/Default/description
- The OpenSSL Project is a collaborative effort to develop a robust, 
- commercial-grade, full-featured, and Open Source toolkit implementing the 
- Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) 
+ The OpenSSL Project is a collaborative effort to develop a robust,
+ commercial-grade, full-featured, and Open Source toolkit implementing the
+ Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  protocols as well as a full-strength general purpose cryptography library.
 endef
 
@@ -43,7 +45,7 @@ endef
 
 define Package/libopenssl/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL shared libraries, needed by other 
+ This package contains the OpenSSL shared libraries, needed by other
  programs.
 endef