get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / package / nvram / src / Makefile
index 3d98209e8583ad5da2b30641d3d3436f8556ae5b..144499ca652ac16b6358639d60ee77219c4bf66c 100644 (file)
@@ -1,16 +1,11 @@
-# $Id$
 
-LIBSHARED_OBJS := shutils.o wl.o wl_linux.o defaults.o linux_timer.o
-LIBNVRAM_OBJS := nvram_linux.o nvram_convert.o
+LIBNVRAM_OBJS := nvram.o
 
-all: libshared.so libnvram.so nvram
+all: libnvram.so nvram
 
 %.o: %.c
        $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c -I. -Iinclude -o $@ $^
 
-libshared.so: $(LIBSHARED_OBJS)
-       $(CC) -shared -o $@ $^
-
 libnvram.so: $(LIBNVRAM_OBJS)
        $(CC) -shared -o $@ $^