major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / package / nvram / Makefile
index cf76c7c812219820924149729a2c18571d873dd9..cc1371ec64156ada6173a5a79bd0a1f3fbebd24d 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -5,15 +11,17 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=nvram
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/nvram
-SECTION:=base
-DEPENDS:=@LINUX_2_4_BRCM
-TITLE:=Broadcom config utility
-DESCRIPTION:=control utility for broadcom's 'nvram' config area
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@TARGET_brcm_2_4
+  TITLE:=Broadcom config utility
+endef
+
+define Package/nvram/description
+ This package contains an utility to control broadcom's 'nvram' config area.
 endef
 
 define Build/Prepare
@@ -21,13 +29,6 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)
 endef
 
-define Package/nvram/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(STAGING_DIR)/usr/lib/
@@ -37,4 +38,13 @@ define Build/UninstallDev
        rm -f $(STAGING_DIR)/usr/lib/lib{nvram,shared}*.so
 endef
 
+define Package/nvram/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,nvram))