major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / package / nvram / Makefile
index ab33c115144e963ecc3ae57e1114ac5704262f4a..cc1371ec64156ada6173a5a79bd0a1f3fbebd24d 100644 (file)
@@ -11,18 +11,17 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=nvram
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nvram
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_4_BRCM
+  DEPENDS:=@TARGET_brcm_2_4
   TITLE:=Broadcom config utility
-  DESCRIPTION:=\
-       This package contains an utility to control broadcom's 'nvram' config \\\
-       area.
+endef
+
+define Package/nvram/description
+ This package contains an utility to control broadcom's 'nvram' config area.
 endef
 
 define Build/Prepare
@@ -40,10 +39,12 @@ define Build/UninstallDev
 endef
 
 define Package/nvram/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,nvram))