backfire: mac80211: b43: backport of r30665
[openwrt-10.03/.git] / package / nvram / Makefile
index c2270714fdd301d1d359d577bdaec9316f30220e..4a57de2e32ea6742bdbf006a8ba87731f1989c65 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2009-2010 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nvram
-PKG_RELEASE:=5
+PKG_RELEASE:=7
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -18,7 +18,7 @@ define Package/nvram
   SECTION:=utils
   CATEGORY:=Base system
   TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
-  DEPENDS:=@TARGET_brcm_2_4||@TARGET_brcm47xx
+  DEPENDS:=@TARGET_brcm_2_4||@TARGET_brcm47xx||@TARGET_ar71xx
 endef
 
 define Package/nvram/description
@@ -41,6 +41,12 @@ define Build/Compile
                LDFLAGS="$(TARGET_LDFLAGS)"
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/libnvram.so.0.1 $(1)/usr/lib/
+       ln -s libnvram.so.0.1 $(1)/usr/lib/libnvram.so
+endef
+
 define Package/nvram/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram