[package] bump some revisions and update copyrights
[openwrt-10.03/.git] / package / mtd / Makefile
index 11a78e8454e94164866b52467de1f0c840236693..adba9dd5ec12145d1b2dbb951db5baefdf8dd147 100644 (file)
@@ -1,16 +1,15 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mtd
-PKG_RELEASE:=7
+PKG_RELEASE:=9
 
 PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
 
@@ -32,10 +31,13 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+target=$(firstword $(subst -, ,$(BOARD)))
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(BOARD)=1"
+               TARGET=$(target) \
+               CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(target)=1 -Wall"
 endef
 
 define Package/mtd/install