mac80211: backport latest version from trunk (as of r28137)
[openwrt-10.03/.git] / package / mac80211 / patches / 400-ath_move_debug_code.patch
diff --git a/package/mac80211/patches/400-ath_move_debug_code.patch b/package/mac80211/patches/400-ath_move_debug_code.patch
new file mode 100644 (file)
index 0000000..47f3b4a
--- /dev/null
@@ -0,0 +1,27 @@
+--- a/drivers/net/wireless/ath/Makefile
++++ b/drivers/net/wireless/ath/Makefile
+@@ -8,6 +8,5 @@ obj-$(CONFIG_ATH_COMMON)       += ath.o
+ ath-objs :=   main.o \
+               regd.o \
+               hw.o \
+-              key.o
+-
+-ath-$(CONFIG_ATH_DEBUG) += debug.o
++              key.o \
++              debug.o
+--- a/drivers/net/wireless/ath/ath.h
++++ b/drivers/net/wireless/ath/ath.h
+@@ -277,13 +277,6 @@ ath_dbg(struct ath_common *common, enum 
+ #endif /* CONFIG_ATH_DEBUG */
+ /** Returns string describing opmode, or NULL if unknown mode. */
+-#ifdef CONFIG_ATH_DEBUG
+ const char *ath_opmode_to_string(enum nl80211_iftype opmode);
+-#else
+-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
+-{
+-      return "UNKNOWN";
+-}
+-#endif
+ #endif /* ATH_H */