mac80211: merge latest changes from trunk (as of r29296)
[openwrt-10.03/.git] / package / mac80211 / patches / 022-atomic64_backport.patch
index 27e2edb711978c6d39124438a4a16b9b08135b0c..673b7c336a6b5a3777718cf8e66f51a458b4489a 100644 (file)
@@ -1,8 +1,8 @@
 --- a/compat/Makefile
 +++ b/compat/Makefile
-@@ -34,3 +34,8 @@ compat-$(CONFIG_COMPAT_KERNEL_2_6_39) +=
-       compat-2.6.39.o \
-       kstrtox.o
+@@ -38,3 +38,8 @@ compat-$(CONFIG_COMPAT_KERNEL_3_1) += \
+       cordic.o \
+       crc8.o
  
 +ifndef CONFIG_64BIT
 +ifndef CONFIG_GENERIC_ATOMIC64
@@ -11,9 +11,9 @@
 +endif
 --- a/include/linux/compat-2.6.31.h
 +++ b/include/linux/compat-2.6.31.h
-@@ -199,6 +199,20 @@ void compat_synchronize_threaded_irq(str
- #define list_entry_rcu(ptr, type, member) \
-       container_of(rcu_dereference(ptr), type, member)
+@@ -202,6 +202,20 @@ void compat_synchronize_threaded_irq(str
+ #define skb_walk_frags(skb, iter)     \
+       for (iter = skb_shinfo(skb)->frag_list; iter; iter = iter->next)
  
 +#ifndef CONFIG_64BIT
 +
  #endif /* LINUX_26_31_COMPAT_H */
 --- /dev/null
 +++ b/compat/compat_atomic.c
-@@ -0,0 +1,29 @@
+@@ -0,0 +1,33 @@
 +#include <linux/spinlock.h>
 +#include <linux/module.h>
 +
++#if !((LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)) && (defined(CONFIG_UML) || defined(CONFIG_X86))) && !((LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33)) && defined(CONFIG_ARM) && !defined(CONFIG_GENERIC_ATOMIC64))
++
 +static DEFINE_SPINLOCK(lock);
 +
 +long long atomic64_read(const atomic64_t *v)
 +}
 +EXPORT_SYMBOL(atomic64_add_return);
 +
++#endif
++
 --- a/include/linux/compat-3.1.h
 +++ b/include/linux/compat-3.1.h
-@@ -24,6 +24,18 @@
- #define genl_dump_check_consistent(...) do {} while(0)
+@@ -19,6 +19,18 @@
+       .prod_id = { NULL, NULL, (v3), NULL }, \
+       .prod_id_hash = { 0, 0, (vh3), 0 }, }
  
 +/*
 + * In many versions, several architectures do not seem to include an
@@ -78,7 +82,7 @@
 + */
 +#include <asm/atomic.h>
 +
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)) && !defined(ATOMIC64_INIT)
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)) && !defined(ATOMIC64_INIT) && !defined(CONFIG_X86) && !((LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33)) && defined(CONFIG_ARM) && !defined(CONFIG_GENERIC_ATOMIC64))
 +#include <asm-generic/atomic64.h>
 +#endif
 +