b43: Add support for removing unnecessary firmware files to reduce the image size.
[openwrt-10.03/.git] / package / mac80211 / Makefile
index 8fadab88bd362eac6ce8b840fe831455bb08c8aa..b3b73fb32d619804b894e1334009f99c44b39896 100644 (file)
@@ -483,6 +483,7 @@ ifneq ($(CONFIG_B43_OPENFIRMWARE),)
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_SUBDIR)/assembler/b43-asm $(STAGING_DIR_HOST)/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_B43_FWCUTTER_SUBDIR)/assembler/b43-asm.bin $(STAGING_DIR_HOST)/bin/
 endif
+       $(INSTALL_BIN) ./files/host_bin/b43-fwsquash.py $(STAGING_DIR_HOST)/bin/
 endef
 
 define KernelPackage/b43/install
@@ -503,6 +504,9 @@ ifneq ($(CONFIG_B43_OPENFIRMWARE),)
 else
        b43-fwcutter --unsupported -w $(1)/lib/firmware/ $(PKG_BUILD_DIR)/$(PKG_B43_FWV4_OBJECT)
 endif
+ifneq ($(CONFIG_B43_FW_SQUASH),)
+       b43-fwsquash.py "$(CONFIG_B43_FW_SQUASH_PHYTYPES)" "$(CONFIG_B43_FW_SQUASH_COREREVS)" "$(1)/lib/firmware/b43"
+endif
 endef
 
 define KernelPackage/b43legacy/install