add updated lua patchset from Steven Barth (cyrus) as explained in http://lists.openw...
[openwrt-10.03/.git] / package / lua / patches / 020-shared_liblua.patch
similarity index 66%
rename from package/lua/patches/010-shared_liblua.patch
rename to package/lua/patches/020-shared_liblua.patch
index 47b37d235e9caf56808a6694ce31612c4fd4fd4f..7942e8760b77d2da28d552e5b6640ddb644cc00c 100644 (file)
@@ -1,24 +1,83 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-
-Index: lua-5.1.3/Makefile
-===================================================================
---- lua-5.1.3.orig/Makefile    2008-02-20 00:06:06.000000000 +0100
-+++ lua-5.1.3/Makefile 2008-02-20 00:06:07.000000000 +0100
-@@ -38,7 +38,7 @@
+diff -ur lua-5.1.3-pt1/Makefile lua-5.1.3-pt2/Makefile
+--- lua-5.1.3-pt1/Makefile     2008-04-05 14:23:14.000000000 +0200
++++ lua-5.1.3-pt2/Makefile     2008-04-05 15:13:38.000000000 +0200
+@@ -37,8 +37,8 @@
  # What to install.
  TO_BIN= lua luac
- TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
+-TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
 -TO_LIB= liblua.a
++TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp lnum_config.h
 +TO_LIB= liblua.a liblua.so liblua.so.$R
  TO_MAN= lua.1 luac.1
  
  # Lua version and release.
-Index: lua-5.1.3/src/Makefile
-===================================================================
---- lua-5.1.3.orig/src/Makefile        2008-02-20 00:06:06.000000000 +0100
-+++ lua-5.1.3/src/Makefile     2008-02-20 00:06:07.000000000 +0100
+diff -ur lua-5.1.3-pt1/src/ldo.h lua-5.1.3-pt2/src/ldo.h
+--- lua-5.1.3-pt1/src/ldo.h    2008-04-05 14:23:14.000000000 +0200
++++ lua-5.1.3-pt2/src/ldo.h    2008-04-05 14:25:40.000000000 +0200
+@@ -46,7 +46,7 @@
+ LUAI_FUNC int luaD_poscall (lua_State *L, StkId firstResult);
+ LUAI_FUNC void luaD_reallocCI (lua_State *L, int newsize);
+ LUAI_FUNC void luaD_reallocstack (lua_State *L, int newsize);
+-LUAI_FUNC void luaD_growstack (lua_State *L, int n);
++LUA_API void luaD_growstack (lua_State *L, int n);
+ LUAI_FUNC void luaD_throw (lua_State *L, int errcode);
+ LUAI_FUNC int luaD_rawrunprotected (lua_State *L, Pfunc f, void *ud);
+diff -ur lua-5.1.3-pt1/src/lfunc.h lua-5.1.3-pt2/src/lfunc.h
+--- lua-5.1.3-pt1/src/lfunc.h  2008-04-05 14:23:14.000000000 +0200
++++ lua-5.1.3-pt2/src/lfunc.h  2008-04-05 14:25:40.000000000 +0200
+@@ -18,7 +18,7 @@
+                          cast(int, sizeof(TValue *)*((n)-1)))
+-LUAI_FUNC Proto *luaF_newproto (lua_State *L);
++LUA_API Proto *luaF_newproto (lua_State *L);
+ LUAI_FUNC Closure *luaF_newCclosure (lua_State *L, int nelems, Table *e);
+ LUAI_FUNC Closure *luaF_newLclosure (lua_State *L, int nelems, Table *e);
+ LUAI_FUNC UpVal *luaF_newupval (lua_State *L);
+diff -ur lua-5.1.3-pt1/src/lmem.h lua-5.1.3-pt2/src/lmem.h
+--- lua-5.1.3-pt1/src/lmem.h   2008-04-05 14:23:14.000000000 +0200
++++ lua-5.1.3-pt2/src/lmem.h   2008-04-05 14:25:40.000000000 +0200
+@@ -38,9 +38,9 @@
+    ((v)=cast(t *, luaM_reallocv(L, v, oldn, n, sizeof(t))))
+-LUAI_FUNC void *luaM_realloc_ (lua_State *L, void *block, size_t oldsize,
++LUA_API void *luaM_realloc_ (lua_State *L, void *block, size_t oldsize,
+                                                           size_t size);
+-LUAI_FUNC void *luaM_toobig (lua_State *L);
++LUA_API void *luaM_toobig (lua_State *L);
+ LUAI_FUNC void *luaM_growaux_ (lua_State *L, void *block, int *size,
+                                size_t size_elem, int limit,
+                                const char *errormsg);
+diff -ur lua-5.1.3-pt1/src/lstring.h lua-5.1.3-pt2/src/lstring.h
+--- lua-5.1.3-pt1/src/lstring.h        2008-04-05 14:23:14.000000000 +0200
++++ lua-5.1.3-pt2/src/lstring.h        2008-04-05 14:25:40.000000000 +0200
+@@ -25,7 +25,7 @@
+ LUAI_FUNC void luaS_resize (lua_State *L, int newsize);
+ LUAI_FUNC Udata *luaS_newudata (lua_State *L, size_t s, Table *e);
+-LUAI_FUNC TString *luaS_newlstr (lua_State *L, const char *str, size_t l);
++LUA_API TString *luaS_newlstr (lua_State *L, const char *str, size_t l);
+ #endif
+diff -ur lua-5.1.3-pt1/src/lundump.h lua-5.1.3-pt2/src/lundump.h
+--- lua-5.1.3-pt1/src/lundump.h        2008-04-05 14:23:14.000000000 +0200
++++ lua-5.1.3-pt2/src/lundump.h        2008-04-05 14:25:40.000000000 +0200
+@@ -17,7 +17,7 @@
+ LUAI_FUNC void luaU_header (char* h);
+ /* dump one chunk; from ldump.c */
+-LUAI_FUNC int luaU_dump (lua_State* L, const Proto* f, lua_Writer w, void* data, int strip);
++LUA_API int luaU_dump (lua_State* L, const Proto* f, lua_Writer w, void* data, int strip);
+ #ifdef luac_c
+ /* print one chunk; from print.c */
+diff -ur lua-5.1.3-pt1/src/Makefile lua-5.1.3-pt2/src/Makefile
+--- lua-5.1.3-pt1/src/Makefile 2008-04-05 14:23:31.000000000 +0200
++++ lua-5.1.3-pt2/src/Makefile 2008-04-05 14:25:40.000000000 +0200
 @@ -23,6 +23,7 @@
  PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
  
@@ -26,7 +85,7 @@ Index: lua-5.1.3/src/Makefile
 +LUA_SO= liblua.so
  CORE_O=       lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
        lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o  \
-       lundump.o lvm.o lzio.o
+       lundump.o lvm.o lzio.o lnum.o
 @@ -33,11 +34,12 @@
  LUA_O=        lua.o
  
@@ -42,7 +101,7 @@ Index: lua-5.1.3/src/Makefile
  
  default: $(PLAT)
  
-@@ -47,15 +49,21 @@
+@@ -47,14 +49,23 @@
  
  a:    $(ALL_A)
  
@@ -60,15 +119,16 @@ Index: lua-5.1.3/src/Makefile
 +      
 +$(LUA_T): $(LUA_O) $(LUA_SO)
 +      $(CC) -o $@ -L. -llua $(MYLDFLAGS) $(LUA_O) $(LIBS)
--$(LUAC_T): $(LUAC_O) $(LUA_A)
--      $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
++
 +$(LUAC_T): $(LUAC_O) $(LUA_SO)
 +      $(CC) -o $@ -L. -llua $(MYLDFLAGS) $(LUAC_O) $(LIBS)
  
+-$(LUAC_T): $(LUAC_O) $(LUA_A)
++$(LUAC_T)-host: $(LUAC_O) $(LUA_A)
+       $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
  clean:
-       $(RM) $(ALL_T) $(ALL_O)
-@@ -96,7 +104,7 @@
+@@ -96,7 +107,7 @@
        $(MAKE) all MYCFLAGS=
  
  linux:
@@ -77,71 +137,3 @@ Index: lua-5.1.3/src/Makefile
  
  macosx:
        $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX MYLIBS="-lreadline"
-Index: lua-5.1.3/src/ldo.h
-===================================================================
---- lua-5.1.3.orig/src/ldo.h   2008-02-20 00:06:06.000000000 +0100
-+++ lua-5.1.3/src/ldo.h        2008-02-20 00:06:07.000000000 +0100
-@@ -46,7 +46,7 @@
- LUAI_FUNC int luaD_poscall (lua_State *L, StkId firstResult);
- LUAI_FUNC void luaD_reallocCI (lua_State *L, int newsize);
- LUAI_FUNC void luaD_reallocstack (lua_State *L, int newsize);
--LUAI_FUNC void luaD_growstack (lua_State *L, int n);
-+LUA_API void luaD_growstack (lua_State *L, int n);
- LUAI_FUNC void luaD_throw (lua_State *L, int errcode);
- LUAI_FUNC int luaD_rawrunprotected (lua_State *L, Pfunc f, void *ud);
-Index: lua-5.1.3/src/lfunc.h
-===================================================================
---- lua-5.1.3.orig/src/lfunc.h 2008-02-20 00:06:06.000000000 +0100
-+++ lua-5.1.3/src/lfunc.h      2008-02-20 00:06:07.000000000 +0100
-@@ -18,7 +18,7 @@
-                          cast(int, sizeof(TValue *)*((n)-1)))
--LUAI_FUNC Proto *luaF_newproto (lua_State *L);
-+LUA_API Proto *luaF_newproto (lua_State *L);
- LUAI_FUNC Closure *luaF_newCclosure (lua_State *L, int nelems, Table *e);
- LUAI_FUNC Closure *luaF_newLclosure (lua_State *L, int nelems, Table *e);
- LUAI_FUNC UpVal *luaF_newupval (lua_State *L);
-Index: lua-5.1.3/src/lmem.h
-===================================================================
---- lua-5.1.3.orig/src/lmem.h  2008-02-20 00:06:06.000000000 +0100
-+++ lua-5.1.3/src/lmem.h       2008-02-20 00:06:07.000000000 +0100
-@@ -38,9 +38,9 @@
-    ((v)=cast(t *, luaM_reallocv(L, v, oldn, n, sizeof(t))))
--LUAI_FUNC void *luaM_realloc_ (lua_State *L, void *block, size_t oldsize,
-+LUA_API void *luaM_realloc_ (lua_State *L, void *block, size_t oldsize,
-                                                           size_t size);
--LUAI_FUNC void *luaM_toobig (lua_State *L);
-+LUA_API void *luaM_toobig (lua_State *L);
- LUAI_FUNC void *luaM_growaux_ (lua_State *L, void *block, int *size,
-                                size_t size_elem, int limit,
-                                const char *errormsg);
-Index: lua-5.1.3/src/lstring.h
-===================================================================
---- lua-5.1.3.orig/src/lstring.h       2008-02-20 00:06:06.000000000 +0100
-+++ lua-5.1.3/src/lstring.h    2008-02-20 00:06:07.000000000 +0100
-@@ -25,7 +25,7 @@
- LUAI_FUNC void luaS_resize (lua_State *L, int newsize);
- LUAI_FUNC Udata *luaS_newudata (lua_State *L, size_t s, Table *e);
--LUAI_FUNC TString *luaS_newlstr (lua_State *L, const char *str, size_t l);
-+LUA_API TString *luaS_newlstr (lua_State *L, const char *str, size_t l);
- #endif
-Index: lua-5.1.3/src/lundump.h
-===================================================================
---- lua-5.1.3.orig/src/lundump.h       2008-02-20 00:06:06.000000000 +0100
-+++ lua-5.1.3/src/lundump.h    2008-02-20 00:06:07.000000000 +0100
-@@ -17,7 +17,7 @@
- LUAI_FUNC void luaU_header (char* h);
- /* dump one chunk; from ldump.c */
--LUAI_FUNC int luaU_dump (lua_State* L, const Proto* f, lua_Writer w, void* data, int strip);
-+LUA_API int luaU_dump (lua_State* L, const Proto* f, lua_Writer w, void* data, int strip);
- #ifdef luac_c
- /* print one chunk; from print.c */