lua: re-enable host builds with some more fixes
[openwrt-10.03/.git] / package / lua / patches-host / 100-no_readline.patch
diff --git a/package/lua/patches-host/100-no_readline.patch b/package/lua/patches-host/100-no_readline.patch
deleted file mode 100644 (file)
index 7368187..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -ur lua-luci-5.1.3/src/luaconf.h lua-luci-5.1.3-new/src/luaconf.h
---- lua-luci-5.1.3/src/luaconf.h       2008-04-14 13:19:54.000000000 +0200
-+++ lua-luci-5.1.3-new/src/luaconf.h   2008-04-14 13:19:17.000000000 +0200
-@@ -38,7 +38,6 @@
- #if defined(LUA_USE_LINUX)
- #define LUA_USE_POSIX
- #define LUA_USE_DLOPEN                /* needs an extra library: -ldl */
--#define LUA_USE_READLINE      /* needs some extra libraries */
- #endif
- #if defined(LUA_USE_MACOSX)
-Nur in lua-luci-5.1.3-new/src: luaconf.h.orig.
-diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
---- lua-luci-5.1.3/src/Makefile        2008-04-14 13:19:57.000000000 +0200
-+++ lua-luci-5.1.3-new/src/Makefile    2008-04-14 13:19:17.000000000 +0200
-@@ -17,6 +17,7 @@
- MYCFLAGS=
- MYLDFLAGS=
- MYLIBS=
-+# USE_READLINE=1
- # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
-@@ -86,7 +87,7 @@
-       @echo "MYLIBS = $(MYLIBS)"
- # convenience targets for popular platforms
--
-+RFLAG=$(if $(USE_READLINE),-DLUA_USE_READLINE)
- none:
-       @echo "Please choose a platform:"
-       @echo "   $(PLATS)"
-@@ -101,16 +102,16 @@
-       $(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN" MYLIBS="-Wl,-E"
- freebsd:
--      $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX" MYLIBS="-Wl,-E -lreadline"
-+      $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX $(RFLAG)" MYLIBS="-Wl,-E$(if $(USE_READLINE), -lreadline)"
- generic:
-       $(MAKE) all MYCFLAGS=
- linux:
--      $(MAKE) all MYCFLAGS+=-DLUA_USE_LINUX MYLIBS="-Wl,-E -ldl -lreadline -lhistory -lncurses"
-+      $(MAKE) all MYCFLAGS+="-DLUA_USE_LINUX $(RFLAG)" MYLIBS="-Wl,-E -ldl $(if $(USE_READLINE), -lreadline -lhistory -lncurses)"
- macosx:
--      $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX MYLIBS="-lreadline"
-+      $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX $(if $(USE_READLINE), MYLIBS="-lreadline")
- # use this on Mac OS X 10.3-
- #     $(MAKE) all MYCFLAGS=-DLUA_USE_MACOSX
-Nur in lua-luci-5.1.3-new/src: Makefile.orig.