Embed luaposix and bitlib into Lua core library
[openwrt-10.03/.git] / package / lua / Makefile
index e5ac938c0ef08b6ce10445966f7fedadf8d46c64..4523ff14b4fef7393badc9ef1a94acb314ce3d8f 100644 (file)
@@ -9,15 +9,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua
-PKG_VERSION:=5.1.3
-PKG_RELEASE:=1
+PKG_VERSION:=5.1.4
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
        http://ftp.gwdg.de/pub/languages/lua/ \
        http://mirrors.dotsrc.org/lua/ \
        http://www.tecgraf.puc-rio.br/lua/ftp/
-PKG_MD5SUM:=a70a8dfaa150e047866dc01a46272599
+PKG_MD5SUM:=d0870f2de55d59c1c8419f36e8fac150
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -87,7 +87,7 @@ endef
 define Build/Configure
 endef
 
-TARGET_CFLAGS += -DLUA_USE_LINUX
+TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC)
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \