more cleanup (make sure to pass TARGET_PATH and not just TARGET_CC)
[openwrt-10.03/.git] / package / linux-atm / Makefile
index 0b8c59d4e157d22f54114f03bc2fbafb39914ab0..56ca90a383788fc331016b158184efe94700b148 100644 (file)
@@ -44,11 +44,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
 endef
 
 define Package/linux-atm/install