more cleanup (make sure to pass TARGET_PATH and not just TARGET_CC)
[openwrt-10.03/.git] / package / libpcap / Makefile
index 2d7aecf55149376ebb851cb517fd591e1af5fd71..155748a4728fdefb4fcd01d38b4711beb890124d 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -14,7 +20,7 @@ PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/libpcap
 SECTION:=base
@@ -55,7 +61,7 @@ define Build/Configure
                        --enable-static \
                        --disable-yydebug \
                        --enable-ipv6 \
-                       --with-build-cc=$(HOSTCC) \
+                       --with-build-cc="$(HOSTCC)" \
                        --with-pcap=linux \
        );
 endef
@@ -65,6 +71,7 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include" \
+               PATH=$(TARGET_PATH) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef