ath9k: rework tx power handling - display the correct *current* tx power, and also...
[openwrt-10.03/.git] / package / libnl / Makefile
index 372b3a3580e576c712f65af733cd785331464843..6802ed16f8a6eb454fa3731c02c40f835b4a720f 100644 (file)
@@ -1,34 +1,35 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl
-PKG_VERSION:=1.0-pre8
-PKG_RELEASE:=1
+PKG_VERSION:=1.1
+PKG_RELEASE:=4
 
-PKG_SOURCE:=libnl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://people.suug.ch/~tgr/libnl/files/
-PKG_MD5SUM:=cc54b3ed25ba45d45a966b9355030810
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=ae970ccd9144e132b68664f98e7ceeb1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libnl
-  SECTION:=net
-  CATEGORY:=Base system
+  SECTION:=libs
+  CATEGORY:=Libraries
   TITLE:=netlink socket library
-  URL:=http://www.suug.ch/~tgr/libnl/
+  URL:=http://people.suug.ch/~tgr/libnl/
 endef
 
 define Package/libnl/description
  This package contains a library for applications dealing with netlink sockets
 endef
 
+TARGET_CFLAGS += -ffunction-sections $(FPIC)
+
 define Build/Compile
        $(call Build/Compile/Default)
        make -C $(PKG_BUILD_DIR) \
@@ -36,19 +37,17 @@ define Build/Compile
                install
 endef
 
-ifneq ($(CONFIG_LINUX_2_6_23),)
+ifneq ($(CONFIG_LINUX_2_6),)
   define Build/InstallDev
+       $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
        mkdir -p $(1)/usr/include/libnl
        $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/libnl/
   endef
 
-  define Build/UninstallDev
-  endef
-
   define Package/libnl/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.1 $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.* $(1)/usr/lib/
   endef
 endif