same propset here as changeset:6500
[openwrt-10.03/.git] / package / keynote / Makefile
index 38f1f6901d969de2dfdd2feb3b02e48841e58719..5e2b3898b96924d4f75f64a3d9daa895eb1304a8 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4619 2006-08-22 09:50:02Z florian $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -35,16 +35,13 @@ define Package/keynote
   URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-static \
-               --enable-shared \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="\$$$$(EXTRA_CFLAGS) \$$$$(EXTRA_LDFLAGS)" \
+               LIBS="$(EXTRA_LDFLAGS) -L. -lkeynote -lm -lcrypto" \
        )
 endef
 
@@ -61,7 +58,7 @@ define Build/UninstallDev
 endef
 
 define Package/keynote/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
 endef