package/kernel: don't depend on kmod-usb-storage when it's built-in
[openwrt-10.03/.git] / package / kernel / modules / usb.mk
index a9498d8266495c104e4731683f262bbe8dcdab2d..86a1858ec64b620325e6af90cbb0e15c9ebace44 100644 (file)
@@ -128,20 +128,6 @@ endef
 
 $(eval $(call KernelPackage,usb-adm5120))
 
-define KernelPackage/usb-octeon
-$(call KernelPackage/usb/Depends,@TARGET_octeon)
-  TITLE:=Support for the Octeon USB OTG controller
-  KCONFIG:=CONFIG_USB_DWC_OTG
-  FILES:=$(LINUX_DIR)/drivers/usb/host/dwc_otg/dwc_otg.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
-endef
-
-define KernelPackage/usb-octeon/description
-  Kernel support for the Octeon USB host controller
-endef
-
-$(eval $(call KernelPackage,usb-octeon))
-
 
 define KernelPackage/usb-isp116x-hcd
 $(call KernelPackage/usb/Depends,@TARGET_ppc40x)
@@ -532,7 +518,8 @@ $(eval $(call KernelPackage,usb-storage))
 define KernelPackage/usb-storage-extras
   SUBMENU:=$(USB_MENU)
   TITLE:=Extra drivers for usb-storage
-  DEPENDS:=@LINUX_2_6 +kmod-usb-storage
+  DEPENDS:=@LINUX_2_6 \
+       +!TARGET_ixp4xx_harddisk||!TARGET_orion_harddisk||!TARGET_x86_olpc:kmod-usb-storage
   KCONFIG:= \
        CONFIG_USB_STORAGE_ALAUDA \
        CONFIG_USB_STORAGE_CYPRESS_ATACB \