package/kernel: don't depend on kmod-usb-storage when it's built-in
[openwrt-10.03/.git] / package / kernel / modules / usb.mk
index 437a199bf49e3542ce16ffd37e0a52268d0385f9..86a1858ec64b620325e6af90cbb0e15c9ebace44 100644 (file)
@@ -518,7 +518,8 @@ $(eval $(call KernelPackage,usb-storage))
 define KernelPackage/usb-storage-extras
   SUBMENU:=$(USB_MENU)
   TITLE:=Extra drivers for usb-storage
-  DEPENDS:=@LINUX_2_6 +kmod-usb-storage
+  DEPENDS:=@LINUX_2_6 \
+       +!TARGET_ixp4xx_harddisk||!TARGET_orion_harddisk||!TARGET_x86_olpc:kmod-usb-storage
   KCONFIG:= \
        CONFIG_USB_STORAGE_ALAUDA \
        CONFIG_USB_STORAGE_CYPRESS_ATACB \