package/kernel: don't depend on kmod-usb-storage when it's built-in
[openwrt-10.03/.git] / package / kernel / modules / usb.mk
index 3d18c0fe441586068c20fd678d1115fd7e570888..86a1858ec64b620325e6af90cbb0e15c9ebace44 100644 (file)
@@ -518,8 +518,8 @@ $(eval $(call KernelPackage,usb-storage))
 define KernelPackage/usb-storage-extras
   SUBMENU:=$(USB_MENU)
   TITLE:=Extra drivers for usb-storage
-  DEPENDS:=@LINUX_2_6 +kmod-usb-storage \
-       @!(TARGET_ixp4xx_harddisk||TARGET_orion_harddisk||TARGET_x86_olpc)
+  DEPENDS:=@LINUX_2_6 \
+       +!TARGET_ixp4xx_harddisk||!TARGET_orion_harddisk||!TARGET_x86_olpc:kmod-usb-storage
   KCONFIG:= \
        CONFIG_USB_STORAGE_ALAUDA \
        CONFIG_USB_STORAGE_CYPRESS_ATACB \