remove kmod-hermes* from package/kernel, it is already provided by the mac80211 package
[openwrt-10.03/.git] / package / kernel / modules / sound.mk
index 53f65e5ad10aebd621d2c85c174603393e94e390..a3d1486346e1305c171d4fedc0efe194539cfc3f 100644 (file)
@@ -10,7 +10,7 @@ SOUND_MENU:=Sound Support
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@AUDIO_SUPPORT
+  DEPENDS:=@AUDIO_SUPPORT +!TARGET_x86:kmod-input-core
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -132,3 +132,16 @@ define KernelPackage/sound-cs5535audio/description
 endef
 
 $(eval $(call KernelPackage,sound-cs5535audio))
+
+
+define KernelPackage/sound-soc-core
+$(call KernelPackage/sound/Depends)
+  TITLE:=SoC sound support
+  KCONFIG:= \
+       CONFIG_SND_SOC \
+       CONFIG_SND_SOC_ALL_CODECS=n
+  FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
+  AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)
+endef
+
+$(eval $(call KernelPackage,sound-soc-core))