remove hacks to disable modules on some targets now that we do have proper PCI &...
[openwrt-10.03/.git] / package / kernel / modules / sound.mk
index a6978070169f2cd531cd882295af550caeb187b7..547fddc8305fab3bfc86b42736081a655577d51b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,10 @@
 
 SOUND_MENU:=Sound Support
 
-# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@USB_SUPPORT||PCI_SUPPORT
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \