port more modules over to the new system
[openwrt-10.03/.git] / package / kernel / modules / other.mk
index 475fcd0defa72f40c594417c809971e20ef05295..97cfddb9e6586b4b16ef81f8f7ac9286aa7c61d1 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -99,3 +99,24 @@ endef
 $(eval $(call KernelPackage,soundcore))
 
 
+define KernelPackage/loop
+  TITLE:=Loopback device support
+  DESCRIPTION:=Kernel module for loopback device support
+  KCONFIG:=$(CONFIG_BLK_DEV_LOOP)
+  SUBMENU:=$(EMENU)
+  AUTOLOAD:=$(call AutoLoad,30,loop)
+  FILES:=$(MODULES_DIR)/kernel/drivers/block/loop.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,loop))
+
+define KernelPackage/nbd
+  TITLE:=Network block device support
+  DESCRIPTION:=Kernel module for network block device support
+  KCONFIG:=$(CONFIG_BLK_DEV_NBD)
+  SUBMENU:=$(EMENU)
+  AUTOLOAD:=$(call AutoLoad,30,nbd)
+  FILES:=$(MODULES_DIR)/kernel/drivers/block/nbd.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,nbd))
+
+