[package] remove the i2c-gpio-custom driver from adm5120, and make it available on...
[openwrt-10.03/.git] / package / kernel / modules / i2c.mk
index c02672f4398c552fedae2c01149c5d4bcfeebeea..687fa9fb2992da2e7e79ecdfcf4eb4903120ce56 100644 (file)
@@ -93,22 +93,6 @@ endef
 $(eval $(call KernelPackage,i2c-gpio))
 
 
-define KernelPackage/i2c-gpio-custom
-  SUBMENU:=$(I2C_MENU)
-  TITLE:=Custom GPIO-based I2C device
-  DEPENDS:=@TARGET_adm5120 kmod-i2c-core +kmod-i2c-gpio
-  KCONFIG:=CONFIG_I2C_GPIO_CUSTOM
-  FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-gpio-custom.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,58,i2c-gpio-custom)
-endef
-
-define KernelPackage/i2c-gpio-custom/description
- Kernel module for register a custom i2c-gpio platform device.
-endef
-
-$(eval $(call KernelPackage,i2c-gpio-custom))
-
-
 define KernelPackage/i2c-scx200
   SUBMENU:=$(I2C_MENU)
   TITLE:=Geode SCx200 I2C using GPIO pins
@@ -135,7 +119,7 @@ define KernelPackage/i2c-scx200-acb
 endef
 
 define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200 
+ Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
  and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
 endef